Custom Fields - Option to hide on backend - Add New Subscription

  • Jonathan Colls
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
9 months 2 days ago #153625 by Jonathan Colls
We have various custom fields where we want to collect information on specific plans.
This works well.
However, if we want to manually add a new subscriber using the Add New option, then all the custom fields are available, and if they are set to mandatory then they need to be filled in, no matter what plan you choose.

It would be good if the admin Add New Subscription would adapt to the Plan chosen to only show the relevant custom fields.
The following user(s) said Thank You: intouchweb

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #154960 by intouchweb
I agree! It also causes issues if an admin wants to update a field for any user, the custom fields show as required, even if they were not required to the user (for example they were added after their last renewal).
This for example means the admin cannot update a phone number and save without ticking boxes on behalf of the user (eg a privacy agreeement).
My thoughts for a solution would be to have a config option to allow us to remove all 'required' validation requirements from fields in the admin area... is that possible Tuan?

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #157224 by Tuan Pham Ngoc
I would add a config option to allow disable validation when subscription is added/edited from backend. That should be simple to implement and help addressing this concern

Tuan

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #157233 by Tuan Pham Ngoc
Hello

I just implemented the option. You can access to My Downloads menu item, download latest package. Then go to Membership Pro -> Configuration, set Validate Backend Subscription Form Data config option to No and there will be no validation when adding/editing subscription record from backend anymore (you might have to clear browser cache to see the change in behavior)

Regards,

Tuan
The following user(s) said Thank You: Jonathan Colls

Please Log in or Create an account to join the conversation.

  • Jonathan Colls
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
2 months 1 week ago #157406 by Jonathan Colls
Thank you Tuan,

This is working well for me.

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #157407 by Tuan Pham Ngoc
You're welcome !

Tuan

Please Log in or Create an account to join the conversation.