EShop is not working when the language is greek !

  • George Papas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 years 6 months ago - 5 years 6 months ago #57535 by George Papas
Hello there,
I bought the eshop module yesterday and now i am working on it for a new site !
When i configured the language content in joomla to Greek i have problem finishing an order ! Below are the steps i did and error in details:

1. I have installed in Joomla the Greek Langiage both in Joomla and in EShop module
2. Configured the Greek Content in the Language->Content
3. Published the 2 plugins regarding the language in the plugins !
4. Added a new category and product in the ESHop module

Now when i try to check out the product in the frontend i got the error: Internal Server Error and from the logs i get the following:

[Fri Feb 06 22:48:21 2015] [error] [client 192.1.1.1] PHP Fatal error: Call to a member function getValue() on a non-object in /var/www/newshop/components/com_eshop/views/checkout/view.raw.php on line 316, referer: web.domain.gr/newshop/index.php/el/compo...op/tameio?Itemid=118

Also when i try to create a new account the same error is shown.... Actually the boxes for filling the 2 addresses details are showing up...

In the rest of the shop though the greek translations are showing up correctly ! When the Language is English everything works fine !

What i am doing wrong ? How can i resolve this ? Help me please !

I have to mention that the shops is offline right now only on my debian web server internally !
Last edit: 5 years 6 months ago by George Papas.

Please Log in or Create an account to join the conversation.

  • George Papas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 years 6 months ago #57578 by George Papas
Replied by George Papas on topic EShop is not working when the language is greek !
Found a solution and a bug !

I just reinstalled the eshop module and everything works fine !

I also did the following to check if this is a bug !
I went on a fresh joomla 3.x version and installed eshop before the language configuration and eshop for some reason the bug appeared ! Eshops needs all the languages to be configured before the actuall installation of the module ! If you do after the products are not showing correctly and the ordering procedure is not working well ! It throws the error i described above !

This is the bug !

Please guide me accordingly for future use of this issue ! If my customer in the future needs a new language why do i have to reinstall the eshop ?

Please Log in or Create an account to join the conversation.

  • Giang Dinh Truong
  • Giang Dinh Truong's Avatar
  • Offline
  • Administrator
  • Administrator
More
5 years 6 months ago #57653 by Giang Dinh Truong
Replied by Giang Dinh Truong on topic EShop is not working when the language is greek !
Hello George,
That because if you install the new languages after setting up in EShop, then you don't have data in other languages than default language EShop. Once you re-install EShop, the EShop will re-check the system and added the missed data in other languages.
Sincerely, Giang

Please Log in or Create an account to join the conversation.

  • George Papas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 years 6 months ago #57664 by George Papas
Replied by George Papas on topic EShop is not working when the language is greek !
Hello there,
Thanks for the anwser ! I can understand for the eshop not showing the products at all ! Not having errors ! The errors i mentioned abve are for products i added after the language configuration. Thus the records for those products exists in both languages Greek and English !
That is the bug !

Please Log in or Create an account to join the conversation.

  • Giang Dinh Truong
  • Giang Dinh Truong's Avatar
  • Offline
  • Administrator
  • Administrator
More
5 years 6 months ago #57753 by Giang Dinh Truong
Replied by Giang Dinh Truong on topic EShop is not working when the language is greek !
Hi George,
I will check that and if I find the bug, I will fix it.
Thank you for reporting it.
Sincerely, Giang

Please Log in or Create an account to join the conversation.

Moderators: Giang Dinh Truong